High Traffic Load Incident - Working on Resolution
Incident Report for ExpandShare
Resolved
We have implemented several updates to address the increased load on our servers. We will continue to monitor today to make sure that we have fully addressed this issue.

Thank you for your continued support.
Posted Jul 28, 2023 - 09:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2023 - 09:06 EDT
Update
We have deployed additional resources to address the increased load. All systems are fully operational now.

We will continue to monitor performance.
Posted Jul 27, 2023 - 14:40 EDT
Investigating
We are currently experiencing heavy traffic load on our servers which may result in slower response times or minor disruption in our services. Our team is aware of the issue and actively working on a solution. We appreciate your patience and understanding as we strive to resolve this as soon as possible.

Thank you for your continued support.
Posted Jul 27, 2023 - 14:19 EDT
This incident affected: App Server and Backend Services.