Intermittent connection with our email service provider Mailgun
Incident Report for ExpandShare
Resolved
Mailgun is continuing to have intermittent connectivity issues. We have switched email providers to AWS and are back up and running at 100%. We are very sorry for any inconvenience that this may have caused you and your teams.

Please let us know if you notice any issues with email services going forward.
Posted Feb 24, 2023 - 14:11 EST
Update
Mailgun is seeing the DDoS attack shifting to the EU region. Our email services continue to be intermittently available. We are investigating alternative solutions at this time.
Posted Feb 23, 2023 - 15:48 EST
Update
We are still seeing intermittent issues with Mailgun. Mailgun is still actively investigating this issue.
Posted Feb 22, 2023 - 10:09 EST
Monitoring
A fix has been implemented by Mailgun and they are monitoring the results.
Posted Feb 21, 2023 - 15:24 EST
Investigating
Mailgun is undergoing intermittent connection issues with their API and SMTP endpoints located in the US.
Posted Feb 21, 2023 - 15:24 EST
This incident affected: Backend Services.